axEl7fB5@lemmy.cafe to linuxmemes@lemmy.worldEnglish · 2 months agoWhich git branch are you on?locklemmy.cafeimagemessage-square145linkfedilinkarrow-up1418
arrow-up1418imageWhich git branch are you on?locklemmy.cafeaxEl7fB5@lemmy.cafe to linuxmemes@lemmy.worldEnglish · 2 months agomessage-square145linkfedilink
minus-squarePotatoesFall@discuss.tchncs.delinkfedilinkarrow-up14·2 months agoWhy master? main is much clearer
minus-squareDerpgon@programming.devlinkfedilinkarrow-up25·edit-22 months agoWhy not change “walkie talkie” to “radio phone”? It is so much cleaner. Because change for the sake of change always brings more work than what it saves. Why change something that works and everyone recognizes it? Of course, if this debate was there when the standard was created…
minus-squareLembot_0004@discuss.onlinelinkfedilinkarrow-up12·2 months agoBecause it is a historically settled down terminology that everyone understands and there is no adequate reason to change it.
minus-squarePotatoesFall@discuss.tchncs.delinkfedilinkarrow-up10·2 months ago everyone understands no, new people learn git every day. ‘main’ is much clearer. It’s maybe not the same readability gain as ‘blocklist/allowlist’ over ‘blacklist/whitelist’, but it’s still there.
minus-squarePotatoesFall@discuss.tchncs.delinkfedilinkarrow-up3·2 months agowe should make the empty string the name for the default branch
Why master? main is much clearer
Why not change “walkie talkie” to “radio phone”? It is so much cleaner.
Because change for the sake of change always brings more work than what it saves.
Why change something that works and everyone recognizes it? Of course, if this debate was there when the standard was created…
Because it is a historically settled down terminology that everyone understands and there is no adequate reason to change it.
no, new people learn git every day.
‘main’ is much clearer. It’s maybe not the same readability gain as ‘blocklist/allowlist’ over ‘blacklist/whitelist’, but it’s still there.
Why main? m is much clearer
we should make the empty string the name for the default branch